Incident: Timbre Down

Incident Report for SharpStream Ltd

Monitoring

Timbre access has now been restored and the platform is operational.

Following the restoration of service, Engineers have been assessing the impact on scheduled recordings and recovery workflows.

A number of recordings were successfully preserved during the incident window. Restoration work has now begun for recordings that were not preserved automatically. Due to the volume of affected content, this process will take some time to complete.

We will provide a further update once restoration activity has been completed.

If there are specific recordings or shows that are particularly time-sensitive, please contact the Support team and we will do our best to prioritise recovery where possible.

We appreciate your patience while this work continues and apologise for the inconvenience caused by today’s outage.
Posted May 18, 2026 - 16:01 UTC

Update

Timbre Access is now restored. We will post an update shortly confirming expected functionality and any restoration actions that need to take place.
Posted May 18, 2026 - 14:18 UTC

Identified

The Timbre CMS platform (timbrecms.sharp-stream.com) remains unavailable, and a number of dependent services are currently impacted.

What remains operational:

- Podcast episodes already distributed to third-party platforms (such as Apple Podcasts and Spotify) continue to play normally.
- Existing RSS feed URLs remain available for content published prior to the incident window.
- Backup playlists and underlying live audio streams continue to operate as expected.
- Analytics reports generated prior to the incident window are unaffected.


Current impact:

- Timbre CMS is unavailable and users are unable to log in or manage content.
- Scheduled recordings due to start or running during the incident window, have failed on the primary recorder and will need to be restored.
- Content set to be published during the incident window will not surface until services are restored.
- Websites and embedded players using Timbre Player or the Timbre API may not display or surface new content correctly.
- New analytics data is currently delayed, meaning in-day reporting will be incomplete until services are restored.


Our engineering team is treating this as a critical priority and is actively working to restore full service. Further updates will be provided as more information becomes available.
Posted May 18, 2026 - 10:47 UTC

Investigating

Our team are aware of an issue affecting users' ability to reach timbrecms.sharp-stream.com. Our team are investigating this now and we'll work to restore access as soon as possible.
Posted May 18, 2026 - 09:36 UTC
This incident affects: TimbreCMS (TimbreCMS user access).