Incident: Portal access limitations
Incident Report for SharpStream Ltd
Resolved
Access has now been restored.
Posted Jul 27, 2024 - 08:12 UTC
Investigating
We are aware of an issue affecting Portal user access. Engineers are working to restore access.
Posted Jul 27, 2024 - 07:56 UTC
This incident affected: Portal (Portal user access).