following a period of monitoring we can confirm the servers in the affected datacentre are stable.
Posted Nov 12, 2025 - 16:25 UTC
Investigating
We are aware of an audience drop across live services that occured this morning at 11:25am. After initial investigation we have isolated the affected audience to a single datacentre.
We shall continue to investigate the nature of this issue to determine a root cause. We do not expect any continual disruption at this time.
Posted Nov 12, 2025 - 12:46 UTC
This incident affected: Network & Infrastructure (Core network devices).