We identified an issue yesterday that caused intermittent buffering and instability on a subset of streams hosted on our Premium infrastructure.
Our engineers investigated immediately and determined that elevated load on one of the ingest servers was impacting its ability to process incoming streams consistently. Mitigating actions were applied to reduce the load on that infrastructure and stability has now been restored.
We are continuing to monitor the platform closely and will complete a deeper review of the underlying behaviour that triggered the condition.
At present all services are operating normally.
If you notice anything unusual on your streams, please let us know and we will investigate immediately.
Posted Mar 11, 2026 - 12:34 UTC
Monitoring
Our engineers have taken mitigating measures to improve load on the server and we have seen stability resume. We shall continue to monitor overnight and tomorrow before considering this as resolved as we continue to ascertain the root cause.
Posted Mar 10, 2026 - 16:47 UTC
Investigating
We are aware of an issue affecting contributions to our ingest-premium-afeeds server. Our team are investigating this issue urgently and we will update this StatusPage incident with our findings and resolution plan.
Posted Mar 10, 2026 - 13:30 UTC
This incident affected: Ingress (Premium ingests).