We have monitored stability since this mornings audience drop. We shall maintain our contact with the service provider to ensure that the necessary actions are taken to mitigate any such occurence in future.
Posted Nov 19, 2025 - 16:54 UTC
Monitoring
At approximately 10:24 this morning, we saw a short period of increased audience disconnections across our network. This will have affected listener connections via multiple ISPs across the UK and EU. Some ISPs will have been disproportionately affected due to their routing preferences (we noticed a disproportionate drop in the UK for connections on Sky, for instance).
Our investigation shows the issue originated from an upstream Internet provider (RETN) whose network sits between our edges and several major ISPs. When their routes briefly degraded, listeners using affected ISPs experienced short connection drops. As such, we do not believe this issue was isolated to the SharpStream network.
There were no platform changes or deployments on our side at the time.
We have already raised this with the provider and are waiting for further detail. We will share any updates as soon as we have them.
Posted Nov 19, 2025 - 11:25 UTC
This incident affected: Network & Infrastructure (Transit providers).